Qontinuum
 Ingeniería Electrónica e Informática aplicadas mapa | contactar | registro | aviso legal | política
Inicio Productos Servicios Sop-Tec Empresa


Sop-Tec

Documentos
Actualizaciones
Base de Conocimientos
Consejos
Instalaciones completas
App tuteladas

info    Información complementaria     info

Procedimiento para la instalación de la aplicación QPres.Web

Procedimiento para la activación del IIS (Internet Information Services)

Uso restringido del programa de utilidad Q2_UTIL en el ecosistema Q-OnTheFly

Procedimiento para adaptar las Instalaciones existentes de WinAcces y MiniPres a la nueva arquitectura

Procedimiento para la activación de la Licencia de Explotación

Procedimiento para adaptar las Instalaciones existentes de QVigila a la utilización de los recursos del subsistema ADA

Procedimiento para adaptar las Instalaciones existentes de QVigila, WinPres y WinProd a la nueva arquitectura para el ecosistema Q-OnTheFly

Proceso para adaptar las prestaciones de "G-SECUR" a Instalaciones con fS=4

Copias de seguridad de la Base de Datos 'Fenix'

Proceso para la conversión al nivel 'Fenix' de los archivos de datos utilizados por el programa de aplicación WinAcces-2n

Proceso para la conversión al nivel 'Fenix' de los archivos de datos utilizados por el programa de aplicación WinProd-1n

Proceso para la conversión al nivel 'Fenix' de los archivos de datos utilizados por el programa de aplicación Hora-1n

Proceso para la conversión al nivel 'Fenix' de los archivos de datos utilizados por los programas de aplicación MiniPres-1n y WinPres-2n

Requisitos de Hardware y de Software para los programas de aplicación del nivel 'Fenix'

 

 

 

 


Procedimiento para la instalación de la aplicación QPres.Web


Cuando la Instalación considere que debe instalar la aplicación QPres.Web puede hacerlo desde el DVD del programa de aplicación WinPres (Versión 7.6 y posteriores) o desde el DVD del programa de aplicación QVigila (Versión 3.2 y posteriores), aunque en todos los casos, y de manera previa, debe existir y estar activado el Servidor IIS.

Una explicación detallada (en forma de tutorial) se puede encontrar en el documento Info-2_A14.pdf.

 

 


Procedimiento para la activación del IIS (Internet Information Services)


Aunque normalmente el Servidor IIS forma parte de los S.O. Windows, no siempre estará disponible para poder ser usado, de manera que es muy probable que deba ser activado cuando en la Instalación se quiera hacer uso de la aplicación QPres.Web.

Una explicación detallada (en forma de tutorial) se puede encontrar en el documento Info-2_A13.pdf.

 

 


Uso restringido del programa de utilidad Q2_UTIL en el ecosistema Q-OnTheFly

Antes de la aparición del "tercer paradigma" de comunicaciones aplicado al ecosistema Q-OnTheFly, el programa de utilidad Q2_UTIL quedaba siempre instalado como consecuencia del proceso de instalación del CD/DVD de cualquiera de los programas de aplicación del nivel Fenix y/o de cualquier otro programa de utilidad (por ejemplo, DELTA/1).

Sin embargo, y debido a las características muy específicas de la arquitectura utilizada en el "tercer paradigma" de comunicaciones (ver el documento MIP-ADA), los Operadores no tienen necesidad alguna de disponer del programa de utilidad Q2_UTIL dado que, además, su uso indiscriminado puede resultar nocivo para el funcionamiento de la Instalación.

En consecuencia se restringe al Administrador del Sistema (Operador "AdminConacc") la posibilidad exclusiva de uso del programa de utilidad Q2_UTIL, para lo cual tal Administrador deberá obtenerlo en la WWW de Qontinuum y deberá instalarlo en el PC que considere oportuno, pero teniendo en cuenta que en tal PC debe existir una instalación previa de cualquier programa de aplicación del ecosistema Q-OnTheFly.

A partir de abril de 2019, los "Service Pack" de los programas de aplicación del ecosistema Q-OnTheFly desinstalan el programa de utilidad Q2_UTIL si existe previamente en el PC, evitando hacerlo cuando haya sido instalado por el Administrador del Sistema bajo el nuevo esquema de seguridad.

 

 


Procedimiento para adaptar las Instalaciones existentes de WinAcces y MiniPres a la nueva arquitectura


Los siguientes programas de aplicación:
   - WinAcces (en todas las Versiones publicadas hasta la 6.2.1)
   - MiniPres (en todas las Versiones publicadas hasta la 6.4.0)
no utilizaban el Servidor QOTF.

A partir de la Versión 7.0 (tanto para WinAcces como para MiniPres), el Servidor QOTF se convierte en un componente esencial para el funcionamiento también de tales programas de aplicación.
El Servidor QOTF opera como un Servicio de Windows, razón por la cual puede estar permanentemente operativo con total independencia de los programas de aplicación, siendo la única condición indispensable para su operatividad que también esté funcionando el PC en el que se halle el RDBMS (podría ser el mismo PC donde corra el Servidor QOTF y/o el programa de aplicación o podría ser otro).

En los DVD de instalación publicados a partir de la aparición de tales Versiones está incorporado el procedimiento adecuado para la instalación, pero para aquellas Instalaciones que estuvieran usando Versiones anteriores está disponible el paquete complementario SC_QOTF.

 

 


Procedimiento para la activación de la Licencia de Explotación


En razón del previsible futuro uso de elementos G-SECUR virtuales, el mecanismo lógico de validación de las Licencias de Explotación ha cambiado a partir de la Versión 1.3 del Servidor QOTF, de manera que, tanto en las nuevas instalaciones como en aquellas preexistentes (con Versiones anteriores a la 1.3), la Licencia de Explotación debe ser activada una primera vez.

Para lograr tal activación hay que seguir el procedimiento explicado en la ayuda en línea en la opción {Ayuda : Licencias} del programa QVigila (de la Versión 1.6 y posteriores) o de los programas WinPres o WinProd (de la Versión 6.2 y posteriores pero sólo cuando utilizan el Módulo funcional modelo Mf_CRM).

 

 


Procedimiento para adaptar las Instalaciones existentes de QVigila a la utilización de los recursos del subsistema ADA


Los siguientes programas de aplicación:
   - QVigila (en las Versiones 1.0 a la 1.4)
no utilizaban al Servidor VirGO dado que tal programa no era compatible con el subsistema ADA.

A partir de la Versión 1.5 (para QVigila), el Servidor VirGO en un Servicio de Windows, razón por la cual puede estar permanentemente operativo con total independencia de los programas de aplicación, siendo la única condición indispensable para su operatividad que también esté funcionando el PC en el que se halle el RDBMS (podría ser el mismo PC donde corra el Servidor QOTF o podría ser otro).

En los DVD de instalación publicados a partir de la aparición de tales Versiones está incorporado el procedimiento adecuado para la instalación, pero para aquellas Instalaciones que estuvieran usando Versiones anteriores está disponible el paquete complementario SC_VirGO.

 

 

 


Procedimiento para adaptar las Instalaciones existentes de QVigila, WinPres y WinProd a la nueva arquitectura para el ecosistema Q-OnTheFly


Los siguientes programas de aplicación:
   - QVigila (en las Versiones 1.0 a la 1.3)
   - WinPres (en la Versión 6.0)
   - WinProd (en la Versión 6.0)
utilizaban al Servidor QOTF de manera local, es decir, desde el mismo PC en el que tales programas se hallaran instalados.

A partir de las Versiones 1.4 (para QVigila) y 6.1 (para WinPres y para WinProd), el Servidor QOTF se convierte en un Servicio de Windows, razón por la cual puede estar permanentemente operativo con total independencia de los programas de aplicación, siendo la única condición indispensable para su operatividad que también esté funcionando el PC en el que se halle el RDBMS (podría ser el mismo PC donde corra el Servidor QOTF o podría ser otro).

En los DVD de instalación publicados a partir de la aparición de tales Versiones está incorporado el procedimiento adecuado para la instalación, pero para aquellas Instalaciones que estuvieran usando Versiones anteriores está disponible el paquete complementario SC_QOTF.

 

 

 


Proceso para adaptar las prestaciones de "G-SECUR" a Instalaciones con fS=4

Cuando una Instalación quiera implantar el uso de elementos del subsistema Calypso y/o quieran utilizar Control de Intrusión y/o quieran utilizar el programa de aplicación QVigila, debe necesariamente utilizar el 'Kit' modelo G-SECUR como complemento para la seguridad. En estos casos, Qontinuum entrega tal 'Kit' con las claves primarias (públicas y privadas) ya grabadas en TInACC/2.

Sin embargo, en aquellas Instalaciones ya existentes y que estuvieran operando con Acreditaciones dotadas con formato fS=4 no es necesario disponer del 'Kit' modelo G-SECUR dado que su funcionalidad es compatible con la de los 'Kit' específicos para el formato fS=4, por lo que lo único que debe realizarse es una actualización lógica del 'Kit' para el formato fS=4 a las nuevas necesidades. Para ello, y sólo bajo petición expresa de la Instalación, Qontinuum generará, sin cargo, un programa de un solo uso que será entregado a la Instalación para que ésta lo ejecute (previo intercambio de claves operativas con Qontinuum) de manera que el elemento TInACC previamente existente en la Instalación pase a tener la Versión 5 (o posterior), por lo que quedará preparado y se comportará como si formara parte del 'Kit' modelo G-SECUR; acabada tal actualización, hay que tener en cuenta que todos los elementos TInACC/1 y/o TInACC/2 que puedan existir en la Instalación también deberán ser actualizados, para lo cual habrá que utilizar las oportunas opciones de la Versión 3.2.1 (o posterior) del programa de utilidad DELTA/3.

 

 

 


Copias de seguridad de la Base de Datos 'Fenix'


Los gestores/motores de Base de Datos de acceso relacional como los usados por el nivel 'Fenix' de los programas de aplicación de Qontinuum para el Control de Accesos, para el Control de Presencia, para la Captura de Datos en Planta y/o para el ecosistema Q-OnTheFly, aportan una notable garantía en lo que respecta a la integridad de los datos dado que, normalmente, el Servidor en el que resida la Base de Datos estará bajo la cobertura de la política de seguridad corporativa para los datos informáticos, por lo que las copias bajo demanda de los propios programas de aplicación no tienen la consideración de "acción imprescindible", y por tanto, normalmente, no serán realizadas.

Sin embargo, existen casos en los que la realización de copias bajo demanda de los propios programas de aplicación tiene razón de ser:
- cuando existe un riesgo muy alto de pérdida de información, lo cual ocurrirá cuando algún tipo de incidente provoque que el disco del PC deba ser un reformateado, por lo que (al residir en el mismo PC el programa de aplicación de Qontinuum haciendo las veces de Servidor y de Cliente) se provocaría un colapso en la explotación.
- al pretender realizar un cambio de plataforma, lo cual ocurre cuando la Instalación moderniza sus equipos informáticos y, por tanto, decide trasladar un programa de aplicación de Qontinuum de un PC (el "actual") a otro (el "nuevo").
- en un proceso de distribución del sistema, lo cual ocurre cuando la Instalación tenía instalado el programa de aplicación de Qontinuum en un único PC (haciendo las veces de Servidor y de Cliente)
y decide separar tales funciones, de manera que la Base de Datos 'Fenix' debe ser pasada a otro PC.
- ante un cambio de gestor/motor, debido a que, por ejemplo, la Instalación quiera pasar de utilizar el gestor MS Access de Microsoft a utilizar el motor SQL Server de Microsoft.

Cuando llegue el momento de tener que afrontar uno de tales casos, habrá que utilizar la última de las copias de seguridad realizadas, para lo cual hay que buscar (en la carpeta en la que se hayan grabado) el archivo más reciente, lo cual se verá por la fecha de los archivos pero también por el propio nombre dado que éste presenta la siguiente composición: "CONACC_BD_aaaa-mm-dd.zip".
El archivo finalmente seleccionado podrá o deberá (segun se trate de uno de los casos citados anteriormente) ser situado en el PC en el que se quiera que resida la Base de Datos 'Fenix' y en el que, previamente y de manera obligatoria, se habrá instalado el programa de aplicación pertinente desde el CD/DVD original.

Al descomprimir el archivo que contiene a la copia seleccionada, aparece un programa de utilidad llamado "QFenix.Utilidades.exe", el cual debe ser ejecutado para lograr la reconstrucción de la Base de Datos 'Fenix' así como para lograr la actualización automática de todos los componentes 'Fenix' a la misma versión que presentaban los utilizados en el equipo en el que se realizó la copia (de esta manera queda garantizada la integridad de los datos y la coherencia entre plataformas).

Una explicación más completa se puede encontrar en el documento Info-2_A6.pdf.

 

 

 


Proceso para la conversión al nivel 'Fenix' de los archivos de datos utilizados por el programa de aplicación WinAcces-2n


ATENCIÓN: este proceso de conversión sólo resultaba factible a partir de la Versión 3 y hasta la Versión 6 del programa de aplicación WinAcces, de manera que ya no resulta posible para la Versión 7 (y posteriores) de tal programa de aplicación en cualquiera de los tres tipos (WinAcces, WinAcces/M o WinAcces/A); sin embargo, la información original (en color gris) se mantiene a efectos históricos.

Aquellas Instalaciones que estén utilizando el programa de aplicación WinAcces-2n y quieran migrar al nivel 'Fenix' de tal aplicación (llamada WinAcces o WinAcces/M o WinAcces/A), tienen forzosamente que convertir la Base de Datos, para lo cual existe el programa de utilidad llamado Migrar_a_Fenix.

La condición previa para la conversión es que se haya realizado la instalación completa del nivel 'Fenix' de la aplicación WinAcces en el mismo PC, durante cuyo proceso de instalación habrá sido creada la carpeta llamada WinAcces-2n, y a ella habrá sido trasladada en bloque el contenido de la antigua aplicación (que por tal motivo habrá pasado a llamarse WinAcces-2n), de manera que el nombre original WinAcces habrá quedado asignado a la Versión 3 (y superiores).

Partiendo de la condición previa de la instalación correcta de la aplicación de nivel 'Fenix', los pasos a seguir son los siguientes:
Paso 1: Ejecutar el programa de utilidad Migrar_a_Fenix (el programa de instalación está incluído en la carpeta Ayuda en el CD/DVD de instalación del producto del nivel 'Fenix').
Paso 2: Si el proceso de conversión detecta errores cualitativos en la información de los archivos originales, aborta el proceso para que el Operador pueda subsanar tales errores desde la aplicación WinAcces-2n (hay que ejecutarla directamente desde la carpeta WinAcces-2n), para a continuación repetir todo el proceso de conversión.

Este proceso de conversión es irreversible dado que, finalmente, elimina la Base de Datos, los archivos, los componentes y el programa de aplicación WinAcces-2n por ser obsoletos al haber migrado al nivel 'Fenix'.


NOTA: para lograr la conversión es imprescindible que tanto el programa de aplicación actual como el nuevo del nivel 'Fenix' estén instalados en el mismo PC, por lo que si se pretendiera (además de la migración) un cambio de PC, primero habría que realizar tal migración en el PC "actual", y sólo después utilizar el recurso de copia del programa del nivel 'Fenix' para, finalmente, recuperar la Base de Datos en el PC "nuevo".

 

 

 


Proceso para la conversión al nivel 'Fenix' de los archivos de datos utilizados por el programa de aplicación WinProd-1n


ATENCIÓN: este proceso de conversión sólo resultaba factible a partir de la Versión 3 y hasta la Versión 6 del programa de aplicación WinProd, de manera que ya no resulta posible para la Versión 7 (y posteriores) de tal programa de aplicación; sin embargo, la información original (en color gris) se mantiene a efectos históricos.

Aquellas Instalaciones que estén utilizando el programa de aplicación WinProd-1n y quieran migrar al nivel 'Fenix' de tal aplicación (llamada WinProd), tienen forzosamente que convertir los archivos de datos, para lo cual existe el producto llamado Migrar_a_Fenix.

Este proceso de conversión es irreversible dado que, finalmente, elimina los archivos, los componentes y los programas que habrán quedado obsoletos al haber migrado al nivel 'Fenix'.

La condición previa para la conversión es que se haya realizado la instalación completa del nivel 'Fenix' de la aplicación WinProd en el mismo PC, durante cuyo proceso de instalación habrá sido creada la carpeta llamada WinProd-1n, y a ella habrá sido trasladada en bloque el contenido de la antigua aplicación (que por tal motivo habrá pasado a llamarse WinProd-1n), de manera que el nombre original WinProd habrá quedado asignado a la Versión 3 (y superiores).

Partiendo de la condición previa de la instalación correcta de la aplicación de nivel 'Fenix', los pasos a seguir son los siguientes:
Paso 1: Ejecutar el programa de utilización especial Migrar_a_Fenix (el programa de instalación está incluído en la carpeta Ayuda en el CD/DVD de instalación del producto).
Paso 2: Si el proceso de conversión detecta errores cualitativos en la información de los archivos originales, aborta el proceso para que el Operador pueda subsanar tales errores desde la aplicación WinProd-1n (hay que ejecutarla directamente desde la carpeta WinProd-1n), para a continuación repetir todo el proceso de conversión.


NOTA: para lograr la conversión es imprescindible que tanto el programa actual como el nuevo del nivel 'Fenix' estén instalados en el mismo PC, por lo que si se pretendiera (además de la migración) un cambio de PC, primero habría que realizar tal migración en el PC "actual", y sólo después utilizar el recurso de copia del programa del nivel 'Fenix' para, finalmente, recuperar la Base de Datos en el PC "nuevo".

 

 

 


Proceso para la conversión al nivel 'Fenix' de los archivos de datos utilizados por el programa de aplicación Hora-1n


ATENCIÓN: este proceso de conversión sólo resultaba factible a partir de la Versión 3 y hasta la Versión 5.4 del programa de aplicación Hora al quedar éste OBSOLETO; sin embargo, la información original (en color gris) se mantiene a efectos históricos.

Aquellas Instalaciones que estén utilizando el programa de aplicación Hora-1n y quieran migrar al nivel 'Fenix' de tal aplicación (llamada Hora), tienen forzosamente que convertir los archivos de datos, para lo cual existe el producto llamado Migrar_a_Fenix.

Este proceso de conversión es irreversible dado que, finalmente, elimina los archivos, los componentes y los programas que habrán quedado obsoletos al haber migrado al nivel 'Fenix'.

La condición previa para la conversión es que se haya realizado la instalación completa del nivel 'Fenix' de la aplicación Hora en el mismo PC, durante cuyo proceso de instalación habrá sido creada la carpeta llamada Hora-1n, y a ella habrá sido trasladada en bloque el contenido de la antigua aplicación (que por tal motivo habrá pasado a llamarse Hora-1n), de manera que el nombre original Hora habrá quedado asignado a la Versión 3 (y superiores).

Partiendo de la condición previa de la instalación correcta de la aplicación de nivel 'Fenix', los pasos a seguir son los siguientes:
Paso 1: Ejecutar el programa de utilización especial Migrar_a_Fenix (el programa de instalación está incluído en la carpeta Ayuda en el CD/DVD de instalación del producto).
Paso 2: Si el proceso de conversión detecta errores cualitativos en la información de los archivos originales, aborta el proceso para que el Operador pueda subsanar tales errores desde la aplicación Hora-1n (hay que ejecutarla directamente desde la carpeta Hora-1n), para a continuación repetir todo el proceso de conversión.


NOTA: para lograr la conversión es imprescindible que tanto el programa actual como el nuevo del nivel 'Fenix' estén instalados en el mismo PC, por lo que si se pretendiera (además de la migración) un cambio de PC, primero habría que realizar tal migración en el PC "actual", y sólo después utilizar el recurso de copia del programa del nivel 'Fenix' para, finalmente, recuperar la Base de Datos en el PC "nuevo".

 

 

 


Proceso para la conversión al nivel 'Fenix' de los archivos de datos utilizados por los programas de aplicación MiniPres-1n y WinPres-2n


ATENCIÓN: este proceso de conversión sólo resultaba factible a partir de la Versión 3 y hasta la Versión 6 de los programas de aplicación MiniPres o WinPres, de manera que ya no resulta posible para la Versión 7 (y posteriores) de tales programas de aplicación; sin embargo, la información original (en color gris) se mantiene a efectos históricos.

Aquellas Instalaciones que estén utilizando los programas de aplicación MiniPres-1n o WinPres-2n y quieran migrar al nivel 'Fenix' de tales aplicaciones (llamadas, respectivamente, MiniPres y WinPres), tienen forzosamente que convertir los archivos de datos, para lo cual existe el producto llamado Migrar_a_Fenix.

Este proceso de conversión es irreversible dado que, finalmente, elimina los archivos, los componentes, los programas y los accesos directos que habrán quedado obsoletos al haber migrado al nivel 'Fenix'.

La condición previa para la conversión es que se haya realizado la instalación completa del nivel 'Fenix' de la aplicación MiniPres o WinPres en el mismo PC, durante cuyo proceso de instalación habrá sido creada la carpeta llamada MiniPres-1n o WinPres-2n, y a ella habrá sido trasladada en bloque el contenido de la antigua aplicación (que por tal motivo habrá pasado a llamarse Minipres-1n o WinPres-2n), de manera que el nombre original MiniPres o WinPres habrá quedado asignado a la instalación de la Versión 3 (y superiores) correspondiente.

Partiendo de la condición previa de la instalación correcta de la aplicación de nivel 'Fenix', los pasos a seguir son los siguientes:
Paso 1: Compactar los archivos de la aplicación ahora llamada MiniPres-1n o WinPres-2n, para lo cual hay que utilizar el programa de utilidad llamado WpUtil (aparece bajo el nombre de "Utilidades de MiniPres" o de "Utilidades de WinPres" dentro de la carpeta MiniPres-1n o WinPres-2n que contiene a la actual aplicación). Ejecutar la opción < Archivos / Reindexar > para cada uno de los archivos de Empleados, Incidencias, Departamentos (sólo para WinPres-2n), Secciones (sólo para WinPres-2n) y Movimientos.
Después, y desde el programa de comunicaciones WinCom, hay que usar la opción < Mantenimiento / Archivo / Reindexar > para reindexar los archivos de Lista_Negra, Tabla Incidencias, Tabla Toques Sirena, Parámetros terminal y Centros.
Paso 2: Ejecutar el programa de utilización especial Migrar_a_Fenix (el programa de instalación está incluído en la carpeta Ayuda en el DVD de instalación del producto).
Paso 3: Si el proceso de conversión detecta errores cualitativos en la información de los archivos originales, aborta el proceso para que el Operador pueda subsanar tales errores desde la aplicación MiniPres-1n o WinPres-2n (hay que ejecutarla directamente desde la carpeta MiniPres-1n o WinPres-2n), para a continuación repetir todo el proceso de conversión.


NOTA: para lograr la conversión es imprescindible que tanto el programa actual como el nuevo del nivel 'Fenix' estén instalados en el mismo PC, por lo que si se pretendiera (además de la migración) un cambio de PC, primero habría que realizar tal migración en el PC "actual", y sólo después utilizar el recurso de copia del programa del nivel 'Fenix' para, finalmente, recuperar la Base de Datos en el PC "nuevo".

 

 

 


Requisitos de Hardware y de Software para los programas de aplicación del nivel 'Fenix'


Los requisitos para cada aplicación del nivel 'Fenix' son distintos dependiendo de su Versión, estando por completo condicionado a la Versión del framework .NET utilizado:

Programas

Versión .NET
(mínima)

Base de Datos 'Fenix' soportada por el RDBMS :

Observaciones
WinPres (Versión 6 y >>)
WinProd (Versión 6 y >>)
- SQL Server 2014 SP1 Con activación del Módulo funcional modelo Mf_CRM
WinPres (Versión 6 y >>)
WinProd (Versión 6 y >>)
- SQL Server 2014 SP1 Sin activación del Módulo funcional modelo Mf_CRM
MiniPres (Versión 6 y >>) - SQL Server 2014 SP1  

WinAcces (Versión 6 y >>)
WinAcces/M (Versión 6 y >>)
WinAcces/A (Versión 6 y >>)
QVigila
(Versión 1 y >>)

- SQL Server 2014 SP1

 
WinAcces (Versión 5)
MiniPres (Versión 5 y >>)
- SQL Server 2014 SP1 Debería ser actualizado a la última Versión disponible
Hora (Versión 5 y >>) - MS Access Programa discontinuado
WinAcces (Versiones 3/4)
WinAcces+ (Versión 4)
WinPres (Versiones 3/4)
MiniPres (Versiones 3/4)
WinProd (Versiones 3/4)
- SQL Server 2005
- Database 10g
- MS Access
Programas discontinuados
Hora (Versiones 3/4) - MS Access Programa discontinuado

 

 

 


Requisitos de Hardware y de Software para los programas de aplicación del nivel 'Fenix' (para .NET 4.5)


Todos los programas de aplicación del nivel 'Fenix' compatibles con Windows 10 y con Windows Server 2012 R2 (publicados a partir de enero de 2019) requieren utilizar el framework .NET en su versión 4.5 y el CrystalReports en su versión 13.0.23, razón por la cual tales componentes deben estar instalados en el PC en el que deban ser ejecutadas las aplicaciones del nivel 'Fenix'.

En todos los DVD de instalación de los productos 'Fenix' que indiquen que son compatibles con Windows 10 se puede encontrar el archivo dotNetFx45_Full_x86_x64.exe (por si se quiere instalar manualmente el framework .NET 4.5) y el archivo CRRuntime_32bit_13_0_23.msi (por si se quiere instalar manualmenten el CrystalReports 13.0.23). Además, tales componentes también pueden ser instalados desde este enlace.

Todos los programas de aplicación del nivel 'Fenix' requieren utilizar un motor de Base de Datos de acceso relacional (RDBMS), el cual puede estar instalado en el mismo equipo en el que vayan a ser ejecutadas tales aplicaciones o en cualquier otro PC conectado a la misma red. A partir de noviembre de 2015, los DVD de instalación del nivel 'Fenix' de los programas de aplicación de Qontinuum incorporan tanto el SQL Server 2014 Express SP1 de Microsoft. Si de manera previa a la instalación del DVD existiera ya instalada en tal equipo una versión soportada (ver requisitos) de uno de tales RDBMS, la Base de Datos 'Fenix' podría quedar asociada al motor existente.

Equipo "típico" para dar soporte a los Clientes:
Los requisitos mínimos y los recomendados que debe cumplir la plataforma necesaria para operar (como Cliente) con las aplicaciones del nivel 'Fenix' son los siguientes:
- procesador a 1 GHz o más;
- memoria RAM de no menos de 2 GB;
- no menos de 1 GB de espacio disponible en disco;
- Sistema Operativo Windows Vista SP2 o Sistema Operativo posterior (se recomienda Windows 10);
- Framework .NET 4.5 y SAP Crystal Reports 13.0.23.

Equipo "típico" para dar soporte a los Servidores:
Los requisitos mínimos y los recomendados que debe cumplir la plataforma necesaria para operar (como Cliente) con las aplicaciones del nivel 'Fenix' son los siguientes:
- procesador a 2 GHz o más;
- memoria RAM de no menos de 4 GB;
- no menos de 1 GB de espacio disponible en disco;
- Sistema Operativo Windows Vista SP2 o Sistema Operativo posterior (se recomienda Windows 10);
- Framework .NET 4.5.

Equipo "típico" para dar soporte al RDBMS:
Los requisitos mínimos y los recomendados que debe cumplir la plataforma necesaria para operar (como Servidor para la Base de Datos 'Fenix') con las aplicaciones del nivel 'Fenix' son los siguientes:
- procesador a 2 GHz o más;
- memoria RAM de no menos de 8 GB;
- no menos de 4 GB de espacio disponible en disco (hay que tener muy en cuenta la ocupación máxima previsible para la Base de Datos 'Fenix' así como la política de copias de seguridad);
- Sistema Operativo Windows Server 2003 (con SP2) o Servidor posterior (se recomienda que no sea anterior a Windows Server 2012 R2);
- Framework .NET 4.5;
- motor SQL Server 2008 para Windows Vista, Windows 7, Windows 8, Windows 8.1 o Windows 10 (se recomienda que no sea anterior a SQL Server 2014 SP1).

Sistemas Operativos compatibles:
Todos los programas de aplicación del nivel 'Fenix' son compatibles con los siguientes Sistemas Operativos de Microsoft (en versiones tanto de 32 bits como de 64 bits):
- Windows Vista SP2
- Windows 7
- Windows 8/8.1
- Windows 10
- Windows Server 2003 SP2
- Windows Server 2008/R2
- Windows Server 2012/R2

Otras consideraciones:

Si tanto en primera instancia como posteriormente debe ser contratado un Módulo funcional que requiera de la presencia del 'Kit' modelo G-SECUR, es muy importante tener en cuenta que tal elemento debe ser enchufado (y permanecer conectado) en un Puerto USB del equipo en el cual se instale el Servidor QOTF.

 

 

 


Requisitos de Hardware y de Software para los programas de aplicación del nivel 'Fenix' (para .NET 2.0)


Todos los programas de aplicación del nivel 'Fenix' en las Versiones 3 (publicadas a partir de marzo de 2007) y 4 (publicadas a partir de junio de 2010) requieren utilizar el framework.NET en su versión 2.0, razón por la cual este entorno de trabajo debe estar instalado en el PC en el que deban ser ejecutadas tales aplicaciones, por lo que en todos los CD de instalación de los productos 'Fenix' de las Versiones 3 y 4 se puede encontrar el archivo dotnetfx2.0.exe por si se quiere instalar el framework 2.0 (en el supuesto de que no exista en el PC tal versión).

Todos los programas de aplicación del nivel 'Fenix' en las Versiones 3 y 4 requieren utilizar un gestor o un motor de Base de Datos de acceso relacional instalado en el mismo PC en el que vayan a ser ejecutadas tales aplicaciones o en cualquier otro PC conectado a la misma red. A partir de septiembre de 2007, los CD de instalación del nivel 'Fenix' en las Versiones 3 y 4 de los programas de aplicación de Qontinuum incorporan tanto el SQL Server 2005 Express Edition (con SP2) de Microsoft. Si de manera previa a la instalación del CD existiera en dicho PC una versión más moderna y/o de superiores prestaciones de uno de tales motores de Base de Datos de acceso relacional, la Base de Datos 'Fenix' podría quedar asociada al motor existente. A partir de junio de 2010, los programas de aplicación del nivel 'Fenix' también pueden operar en base al gestor MS Access(*), aunque éste sólo debería ser usado para instalaciones con pocos requisitos (no más de unos cien mil marcajes acumulados en el tiempo) en lo que afecta a la gestión de Bases de Datos; por ejemplo, una Instalación con 50 Usuarios a 2 Marcajes por día (o 25 Usuarios a 4 Marcajes por día) genera unos 24.000 marcajes anuales, por lo que tal tipo de Instalación podría utilizar MS Access para guardar la información de 4 años al no superar el límite máximo recomendado.
(*) Atención: el programa de aplicación Hora sólo puede utilizar el gestor MS Access.

Los requisitos mínimos y los recomendados que debe cumplir la plataforma necesaria para operar con las aplicaciones del nivel 'Fenix' en las Versiones 3 y 4 son los siguientes:
- procesador Pentium-III (o equivalente) a 500 MHz o más (se recomienda no menos de 1 GHz);
- memoria RAM de 192 MB o más (se recomienda no menos de 512 MB);
- no menos de 50 MB de espacio disponible en disco;
- Sistema Operativo Windows 2000 (con SP4) o Windows Server 2003 (con SP1) o Windows Server 2008 o Windows XP (con SP2) o Windows Vista o Windows 7;
- framework .NET 2.0 (o superior), pero es obligado tener instalado Internet Explorer 6 (con SP1) o una versión superior;
- motor SQL Server 2000 (se recomienda SQL Server 2005) o motor Database anterior al 10g (se recomienda Database 10g);
- MDAC 2.60 (o superior).

Los requisitos mínimos y los recomendados que debe cumplir la plataforma necesaria para operar con uno de los antedichos motores de Base de Datos son los siguientes:
- procesador Pentium-III (o equivalente) a 500 MHz o más (se recomienda no menos de 1 GHz);
- memoria RAM de 192 MB o más (se recomienda no menos de 512 MB);
- no menos de 600 MB de espacio disponible en disco;
- Sistema Operativo Windows 2000 (con SP4) o Windows Server 2003 (con SP1) o Windows Server 2008 o Windows XP (con SP2) o Windows Vista o Windows 7;
- framework .NET 2.0 (o superior), pero es obligado tener instalado Internet Explorer 6 (con SP1) o una versión superior;
- MDAC 2.60 (o superior).

 

 

webmaster@qontinuum-plus.com
       T/. +34 932451628    M/. +34 610119235
c/. Ausiàs Marc, 71, entresol 2ª   08013 Barcelona
Página actualizada: 11-06-2019 Copyright © 1999-2019, Qontinuum Plus, S.L.
Todos los derechos reservados